Vanaf 12 augustus gaat Internet Explorer verouderde versies van plug-ins blokkeren. Aanvankelijk gaat het daarbij enkel om oudere versies van java. Verouderde plug-ins worden vaak gebruikt door aanvallers om malware te installeren.

Als gebruikers een verouderde java-versie draaien en op een website komen die java gebruikt, krijgen ze vanaf 12 augustus een waarschuwing en wordt de plug-in automatisch geblokkeerd; dat valt samen met de update voor Windows 8.1, maar die heeft alleen IE11. De blokkade geldt ook voor oudere versies van Microsofts browser en dus op oudere besturingssystemen.

Desgewenst kan een gebruiker ervoor kiezen om de plug-in toch te draaien. Aanvankelijk gaat het enkel om oudere versies van java, maar Microsoft wil ook verouderde versies van andere browser-plug-ins gaan blokkeren.

Microsoft werkt de lijst met verouderde plug-ins automatisch bij, buiten Windows Update om. Firefox en Chrome blokkeren al langer verouderde java-versies. Volgens Microsoft richt een groot deel van de malware-aanvallen op internet zich op java – vorig jaar lag dat elke maand tussen de 84,6 en 98,5 procent. Aanvallers gebruiken gaten in de verouderde plug-ins om malware te installeren, bijvoorbeeld door advertentienetwerken te infecteren.